Update MacOS

The Sigilium plugin for MacOS is compatible with High Sierra (10.13) and higher

If you are using an older version of MacOS, you will need to update in order to use Sigilium

1. Go to about "About this mac"

2. Clic on "Softwarepdate"

3. Update the MacOS if needed (current is older than 10.13)

Still need help? Contact Us Contact Us